利用n管理node版本,轻松切换node

2019年9月7日 评论

前言

这段时间,一直都是用node的稳定版本,最近因为工作需要,需要用到其他node版本,Google搜了一下,有很好的一个解决方案,选择node版本管理工具,轻松切换node。有两个很好的node版本工具, nvmn ,那么问题来了,选择哪一个呢? 废话,当然是哪个好用就用哪个嘛! 虽然热度 nvmn 高一点,无意中看到FED写的一篇blog《管理 node 版本,选择 nvm 还是 n?》,觉得 n 比较简单易用,然后就毫不犹豫地选择了 n,全局安装之后输入命令就可以无缝切换了。
简单易用 n github地址: https://github.com/tj/n nvm github地址:https://github.com/creationix/nvm

安装

$ npm install -g n
下载完成后就可以使用 n 了。

利用 n 下载所需node

$ n 版本号   
下载最新版本
$ n latest
删除某个版本
$ n rm 4.4.4 
查看当前 node 版本
$ node -v
切换版本
$ n

  6.9.4
ο 7.4.0
  4.4.4
以指定的版本来执行脚本
$ n use 7.4.0 index.js
作者:周星星学编程 链接:https://www.jianshu.com/p/c641dcc47b48 来源:简书 简书著作权归作者所有,任何形式的转载都请联系作者获得授权并注明出处。
weinxin
我的微信
爱生活、爱学习的小伙伴可以通过扫一扫二维码添加我的个人微信一起交流!
正确的安装和使用nvm(mac) Node.js

正确的安装和使用nvm(mac)

前言 目前主流的node版本管理工具有两种,nvm和n。两者差异挺大的,具体分析可以参考一下淘宝FED团队的一篇文章: 管理 node 版本,选择 nvm 还是 n? 总的来说,nvm有点类似于 Py...
nodejs 请求数据不完整问题解决 Node.js

nodejs 请求数据不完整问题解决

今天用nodejs请求天气数据时遇到使用JSON.parse()解析数据时始终报错的问题,仔细调试后才发现获取到的json字符串莫名的丢掉了一部分; const https = require('ht...
匿名

发表评论

匿名网友